
TimeSource to QuickBooks Pro Timer Interface 
 
 

Introduction 
 
The TimeSource payroll export for QuickBooks Pro has been augmented by a new payroll 
export for QuickBooks Pro/Premier 2002 (or newer) using the Timer function of 
QuickBooks.  Both exports are included with TimeSource Lite and TimeSource Full. 
 
The older TimeSource export may be used with any version of QuickBooks Pro/Premier 
prior to 2002, and works by making an export file, which is then imported by QuickBooks.  
TimeSource and QuickBooks are not required to be on the same computer. 
 
The newer TimeSource QuickBooks export uses features built into only the most recent 
versions of QuickBooks Pro/Premier and therefore works only with versions of 
QuickBooks 2002 and newer.  This most recent TimeSource QuickBooks export 
communicates directly with the QuickBooks Pro/Premier program and employee hours are 
written directly into the QuickBooks data files.  The current version of the TimeSource 
QuickBooks export requires that both TimeSource and QuickBooks be installed on the 
same machine. 
 
Both interfaces produce the same result, but by different methods. 
 
These instructions cover installing, configuring and running the new TimeSource 
QuickBooks payroll export.  The instructions for the older export are located in the 
TimeSource manual.   
 
 

Requirements 
 
Check with Intuit for the current QuickBooks computer system requirements.  The 
requirements for TimeSource are less stringent. 
 
Icon Time is using release two of the Intuit interface, and you must have release two 
compatibility in your copy of QuickBooks. 
 
Both the QuickBooks and TimeSource applications must be installed on the same 
computer. 
 
QuickBooks must be set to Single User mode. 
 
Each employee’s Full name in TimeSource must match the employee’s name in 
QuickBooks. 
 
Each pay code set up in the TimeSource Payroll Export screen must have a 
corresponding Payroll Item in QuickBooks.    
 
 



 2

Installation 
 
Before preceding the TimeSource QuickBooks export program needs to be installed on 
the computer.  The program, called QBPlusExport.exe, is not installed during the 
TimeSource installation.  The installation file called SetupTS_7Qbinterface.exe is located 
on the following path: 
  
 CD ROM:\QbTimerInterface\SetupTS_7Qbinterface.exe 
 
Please place your TimeSource CD in the computers CD ROM drive and using a Windows 
Explorer window navigate to the SetupTS_7Qbinterface.exe file at the path above.  To run 
the setup program just double click on the file and proceed with the install. 
 
 

Setup TimeSource 
 
Before attempting the TimeSource QuickBooks export certain fields in TimeSource need 
to be configured for the export to work.   
 
Export Type 
 
From the TimeSource SwitchBoard open the Payroll Export screen by clicking on the 
Payroll Export button under the File heading.  Please set the “Export Type” field of the 
Payroll Export screen to “QuickBooks Pro Timer”.   Refer to the circled area of Figure 1.   
 
 

 
Figure 1.  
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Since the QuickBooks Pro Timer export sends the TimeSource punch data directly to the 
QuickBooks database file an “Export Path” is not required.  Please leave the “Export Path” 
as <no path>. 
 
Export Codes 
 
In the same Payroll Export window enter the TimeSource “Export Codes”.  The circled 
area of Figure 2 shows where you need to enter the “Export Codes”.   
 
In the example below all regular hours in TimeSource are exported to QuickBooks with 
the Regular code, OT1 hours with the Overtime code and so on.  The “Export Codes” 
must each match a “Payroll Item” code in QuickBooks.  The codes listed below are just 
suggestions if you have existing “Payroll Items” setup in QuickBooks please enter those 
values in as the Export Codes.  Please refer to the information at Figure 5, Setting up 
Payroll Items, to see what “Payroll Item” codes you currently have established.   
 
IMPORTANT.  TimeSource limits the export of regular time to a single code.  If you have 
multiple “Payroll Item’s” in QuickBooks for regular time a single Payroll Item must be 
selected for the export of the information.   
 
The example below was taken from TimeSource Lite if you have TimeSource Full you will 
additional codes.  The “Export Codes” are limited to 10 characters in length. 
 
 

 
Figure 2. 

 
 
Employee Name 
 
From the TimeSource SwitchBoard open the Employee screen by clicking on the 
“Employee” button under “Edit”.  Each employee’s “Full Name” must match the 
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corresponding employees name in QuickBooks.  Please refer to the circled area of Figure 
3 to see where to edit the “Full Name” in TimeSource.  
 
 

 
Figure 3. 

 
 
The employee “Full Name” in TimeSource must match the name displayed in the 
QuickBooks Employee List as shown in Figure 5. 
 

Setup QuickBooks 
 
This user guide is not a primer on the use of QuickBooks Pro.  However, there are a few 
operations that must be performed before the interface will run.  Our purpose here is just 
to point them out.  Refer to your Intuit documentation for details on how to accomplish 
these steps. 
 
Enabling Time Tracking 
 
Before you try to run the interface, check the Edit->Preferences menu of QuickBooks     
and make sure that you have selected to track time.  
 
 In the “Preferences” screen select “Time Tracking”.  Then select the “Company 
Preferences” tab of the “Time Tracking” screen.  Make sure the “Yes” radio button is 
selected for “Do You Track Time” as shown in figure 4.   
 
If “Track Time” is not set to “Yes” the TimeSource QuickBooks Pro Timer interface will 
simply not run. 
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Figure 4. 

 
 
Employee Name 
 
Each employee’s name in the QuickBooks Employee List, Figure 5, must match the 
corresponding employee’s “Full Name” in TimeSource, Figure 3.  If the names are not the 
same, change the “Full Name” in TimeSource to match the employee’s name in the 
QuickBooks Employee list.  If this is not possible, double click on the employees name to 
make the edit in QuickBooks.   
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Figure 5. 
Setting up Payroll Items 
 
Before QuickBooks will accept information from the TimeSource program the Payroll Item 
list in QuickBooks must be edited so the “Payroll Items” match “Export Codes” entered in 
the “QuickBooks Pro Timer” payroll export screen of TimeSource, Figure 2.  To access 
the Payroll Item list select Lists>Payroll Item from the QuickBooks menu bar.   
 
See Figure 6 to see an example of the Payroll Item list of QuickBooks.    The circled area 
of Figure 6 show the “Payroll Items” used in this example.    
 
The Payroll Item list is pre-configured with certain “Federal Tax “ entries.  For our 
purposes you can ignore these items.   
 
You can use one of three possible methods to configure you QuickBooks “Payroll Items” 
to match TimeSource “Export Codes”. 
 

1. If you have existing “Payroll Items” other than the “Federal Tax” entries you can 
enter your existing “Payroll Items” as “Export Codes” in the “QuickBooks Pro 
Timer” payroll export interface.   In our example your current “Payroll Item” for 
regular time would replace the Regular “Export Code” in QuickBooks Pro Timer 
interface screen, Figure 2, as long as the Payroll Item name did not exceed 10 
characters in length.  

 
2. If using your existing “Payroll Items” is not an option you can edit the names of an 

existing “Payroll Item” to match an “Export Code” name already entered into the 
“QuickBooks Pro Timer” export interface.  Simply edit an existing “Payroll Item” by 
double clicking on the item name.  Enter the new “Payroll Item” name following the 
instructions displayed until the existing item has been updated.   In our example an 
existing “Payroll Item” would be edited to Regular to correspond to the Regular 
“Export Code” in TimeSource. 

 
3. If you need to add a new “Payroll Item” to the list, select the “Payroll Item” button 

at the bottom of the Payroll Item screen and then select “New”.  QuickBooks will 
ask which method you want to use to set up the “Payroll Item”.  Select “Custom”.  
Follow the instructions on the following screens to add the new “Payroll Item”.  
Make sure the name of the new “Payroll Item” matches one of the “Export Codes”, 
Figure 2, in the “QuickBooks Pro Timer” interface.  In our example the new “Payroll 
Item” for regular hours would be named Regular as it is in the “QuickBook Pro 
Timer” export interface. 
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Figure 6. 

 
 
 
For our example after all of the “Payroll Items” have been entered the screen will look like 
the circled area of Figure 6 and the “QuickBooks Pro Timer” export interface will look like 
Figure 2.   
Again the names of the “Payroll Items” listed in Figure 6 are just suggestions.  Please use 
the “Payroll Item” name appropriate for your set up making sure they have matching 
“Export Codes” in TimeSource.  
 
Assigning Payroll Items to Employees 
 
Once the “Payroll Items” have been entered into the Payroll Item list each item must be 
assigned to an employee.  To assign the “Payroll Items” to each employee please open 
the Employee list by selecting Lists>Employee Lists from the QuickBooks menu bar, 
Figure 7.  
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Figure 7. 

 
 
Double click on the first employee in the list.  This opens the “Personal Info” screen for 
this employee as shown in Figure 8.  From the “Change Tabs” drop down of the Edit 
Employee screen select the “Payroll and Compensation Info” option as shown if Figure 8. 
   
 

 
Figure 8. 
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In the “Payroll and Compensation Info” screen please assign each “Payroll Item” and 
corresponding pay rate to the employee.  Please refer to the circled area of Figure 9. 
 
 

 
Figure 9. 

 
 
Its important to note here that each employees “Use time data to create paychecks” 
located in the circled area of Figure 9 must be checked.  
 
 
Run Export 
 
Start QuickBooks 
 
Start QuickBooks manually and leave the program running the very first time you run the 
export.  Failure to do so will result in error messages because a connection cannot be 
established between TimeSource and QuickBooks.   
 
Start TimeSource 
 
Start TimeSource.  Open the Payroll Export screen by selecting File>Payroll Export from 
the TimeSource Switchboard.  Please make sure the “Export Type” is set to QuickBooks 
Pro Timer as shown if Figure 10.   In addition make sure you have entered the appropriate 
Export Codes as demonstrated in Figure 2.   
 
From the Payroll Export screen select the Time Frame for your export.  Next select the 
“All” value from the drop down list for both the Employee and the Department field.  Begin 
the export process by clicking on the “Run Export” in Figure 10. 
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Figure 10. 

 
 
 
Locate the TimeSource Application 
 
Before the export can run it needs to locate the TimeSource applications file, 
tsourcev7.mde.  Select Ok in the “Locate TSDATA” screen, Figure 11.   
 
 
 

 
Figure 11. 

After selecting “Ok” a typical Windows 
“Open” file window appears, Figure 12.  To 
continue you must locate the TimeSource 
application file in this window and open the 
file.   
 
The TimeSource application is typically 
installed on the following page C:\Program 
Files\Tsourcev7\Tsourcev7.mde.  Navigate 
to the Tsourcev7 folder in the “Open” 
window and highlight the “Tsourcev7.mde” 
file and then select open.   

 
 
 
If you have installed TimeSouce in a different folder navigate to that folder and open the 
tsourcev7.mde file located there. 
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Figure 12.   

 
 
Locate the QuickBooks Data File 
 
Next you will be prompted to locate your QuickBooks data file.  The QuickBooks data file 
has a .QBW extension and is usually named after the company.   
 
 

 
Figure 13. 

After selecting “Ok” a typical Windows 
“Open” file window appears, Figure 14.  To 
continue you must locate your QuickBooks 
data file in this window and open the file.   
 
The QuickBooks data file is typically 
installed on the following path C:\Program 
Files\Intuit\QuickBooks Pro\Company 
Name.QBW.  Where the “Company 
Name.QBW” file will be the name of your 
QuickBooks data file.  Navigate to the file in 
the “Open” window, highlight the file and 
select “Open”.   

 
 
 
If the QuickBooks data file is in a different location navigate to that location and open the 
file. 
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Figure 14. 

 
 
Respond to QuickBooks 
 
QuickBooks must be running the first time you run this interface.  QuickBooks recognizes 
that a new application is asking for access to the data, and responds with the following 
dialog box, Figure 15.  
 
 

 
Figure 15.   

 
 
The TimeSource interface does not require access to Social Security Numbers and other 
personal data, so you do not need to check the option. 
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Click either “Yes, this Time” Or “Yes, Always” to proceed with the data transfer.   
 
If you select “Yes, this Time” then you must run QuickBooks manually before running this 
interface again, and QuickBooks will prompt you with this same screen. 
 
If you select “Yes, Always” then this screen will not appear again.  Whether you need to 
run QuickBooks manually or not depends on how you structure QuickBooks Preferences 
at a later step. 
 
In either case, the TimeSource interface begins its work. 
 
 
Check for Unresolved Issues 
 
After allowing TimeSource to access the QuickBooks data the “QuickBooks Pro Timer 
(Payroll Export)” screen is automatically opened, Figure 16.   
 
TimeSource validates the export data as much as possible before allowing the export to 
complete.  
 
 

 
Figure 16. 

 
Any employees or payroll items which 
cannot be found in your QuickBooks 
data file will be reported here as an 
unresolved issue.  These issues may 
represent a simple difference in 
spelling, or a data item that is actually 
missing in QuickBooks. 
 
Any issues reported in the 
“QuickBooks Pro Timer (Payroll 
Export)” screen must be resolved in 
either TimeSource or QuickBooks 
before returning here and running the 
interface again.  The interface will not 
allow you to proceed with unresolved 
issues.  You may want to use the 
“Print Screen” button to generate a 
quick list of issues.  

 
 
Check After Resolving Issues 
 
When the QuickBooks Pro Timer (Payroll Export) programs no longer detects any issues 
between the TimeSource export data and QuickBooks the screen in Figure 17 appears. 
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Figure 17.   

 
The data is now ready to export to 
QuickBooks.  Before proceeding with 
the export it is advisable to make a 
backup of your QuickBooks data.  If 
for whatever reason something 
unexpected happens during the 
export you only need to restore the 
QuickBooks backup file.  If you decide 
to make a back up of your 
QuickBooks data select the “Close” 
button and run the export again after 
creating the backup.  
 
To run the export click on the “Export” 
button.   

 
 
Export Completed 
 
When the export has completed the window in Figure 18 is displayed. 
 
 
 

 
Figure 18. 

 
With the error checking performed 
prior to the data exchange, it is 
extremely unlikely that an error would 
occur during the actual transfer of 
data during the export.  If this should 
ever happen, the screen in Figure 18 
will inform you of that fact and will tell 
you in which file it has saved the 
transaction results.  That file is 
formatted as XML data, and may be 
viewed in a browser. 
 
You have successfully completed the 
export.  Click the close button to exit 
the export screen.   
 
Open QuickBooks to view the 
exported data.   
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View the Results in QuickBooks 
 
 
The first time you complete a data transfer, you will most likely want to view the results of 
the export.  To view the export, open the Weekly Timesheet screen by selecting 
Employees>Time Tracking>Use Weekly TimeSheet… from the menu bar, Figure 19. 
 
 
 

 
Figure 19. 

 
 

When the “Weekly Timesheet” opens it defaults to a blank timesheet.   
 
Select an employee by choosing the drop down arrow next to the “Name” label in the 
“Weekly Timesheet” as shown in Figure 20.   
 
Please make sure you select an employee whose time was included in the export. 
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Figure 20. 

 
 
Once an employee has been selected from the drop down list the employee’s time 
information is displayed as shown in Figure 21. 
 
 

 
Figure 21. 

 
If the “Weekly Timesheet” is displaying the incorrect time period use the “Previous” or 
“Next” options circled in Figure 21 to locate the correct export time period. 
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Unattended Operation 
 
It is possible to allow TimeSource to run QuickBooks in the background while exchanging 
data so that you will not have to manually start QuickBooks.  If you choose this method of 
operation, you must authorize TimeSource to access QuickBooks always by editing the 
“Access to QuickBooks Company File” screen. 
 
Navigate to the screen by selecting Edit>Preferences from the menu bar.  In the 
Preferences window select the “Integrated Applications” preference screen and then 
select the “Company Preferences” tab, as shown in Figure 22.  
 
 Highlight the TimeSource interface line and click Properties.  
 
 

 
Figure 22. 

 
 
Click the “Access Rights” tab.  Enable “Allow this application to access this company file”.   
 
Then enable the “Allow this application to login automatically” and select a user from the 
dropdown list box as shown in Figure 23. 
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Figure 23. 

 
 
The selected user will now be able to run the Payroll Export from TimeSource and it will 
not be necessary to manually start QuickBooks first.  The QuickBooks Operation will be 
transparent to the user. 


